Outlook for Windows version Requirements Change

As of November 1st Microsoft changed its minimum version requirements for connecting Outlook for Windows to Office 365. Outlook 2013 Service Pack 1 and later will be able to connect to Microsoft 365, however, older versions will no longer be able to connect to these services. With these changes Microsoft is hoping to improve security of it services.
Read More